Difference between revisions of "SMF2.0:Requirements and recommendations"

From Online Manual

Jump to: navigation, search
(Formatting.)
m
 
(38 intermediate revisions by 12 users not shown)
Line 1: Line 1:
To run an SMF forum the server it resides on, as well as the browsers used by its users, will need to meet some specified requirements. Additionally, there are some recommended requirements that may give advanced capabilities to users.  
+
In order to run an SMF forum, the server must meet the following requirements, and will run best on servers that also meet the recommendations below. This software has been tested and verified to work with the clients listed below, which are all internet browsers.  
  
 
==Basic Server Requirements==
 
==Basic Server Requirements==
Line 5: Line 5:
 
The following are required on any server intending to run SMF 2.0.
 
The following are required on any server intending to run SMF 2.0.
  
 +
* A webserver with approximately 20MB of available disk space. Much more is recommended so that other content can be uploaded over time.
 +
* A webserver that supports PHP, such as Apache or Internet Information Server (IIS).
 
* [http://www.php.net PHP] 4.1.0 or higher
 
* [http://www.php.net PHP] 4.1.0 or higher
* The following must be changed in the php.ini file.
+
** Versions of SMF below 2.0.7 will not work on PHP 5.5. If you use PHP 5.5 it is necessary to use SMF 2.0.7 or greater.
 +
** Versions of SMF from 2.0.14 onwards require a version of PHP between 5.4 and 7.1.  If you use PHP 5.3 or lower, it is necessary to use SMF 2.0.13 or lower. PHP 7.2 is not supported by SMF at this time.
 +
* The following must be changed in the php.ini file:
 
** The <code>engine</code> directive must be set to On.
 
** The <code>engine</code> directive must be set to On.
 
** The <code>magic_quotes_sybase</code> directive must be set to Off.
 
** The <code>magic_quotes_sybase</code> directive must be set to Off.
Line 12: Line 16:
 
** The <code>file_uploads</code> directive must be set to On.
 
** The <code>file_uploads</code> directive must be set to On.
 
** The <code>upload_tmp_dir</code> directive must be set to a valid directory or empty.  
 
** The <code>upload_tmp_dir</code> directive must be set to a valid directory or empty.  
* One of the following databases must be installed.
+
* One of the following databases must be installed:
** [http://www.mysql.com MySQL] 4.0.18 or higher (at least 4.1.0 would be better).
+
** [http://www.mysql.com MySQL] 4.0.18 or higher (at least 4.1.0 would be better) and PHP MySQL client API 4.0.18 or higher.
** [http://www.postgresql.org PostgreSQL] 8.0 or higher
+
**[http://www.postgresql.org PostgreSQL] 8.0 or higher (<code>standard_conforming_strings</code> must be set to off, starting from PostgreSQL 9.1 default is on)
** [http://www.sqlite.org SQLite] 2.8.
+
** [http://www.sqlite.org SQLite] SQLite 2.x (SMF is not compatible with SQLite 3.x)
* The following are required of the database.
+
* The following are requirements for the database:
** There must be at least 2 MB of storage space in the database, although more is highly recommended.
+
** For a clean SMF installation, at least 2 MB of storage space in the database. Please note that this is only enough for the installation.
 
** The database user must have ''at least'' the following privileges: <code>SELECT</code>, <code>INSERT</code>, <code>UPDATE</code>, <code>DELETE</code>, <code>ALTER</code>, and <code>INDEX</code>.
 
** The database user must have ''at least'' the following privileges: <code>SELECT</code>, <code>INSERT</code>, <code>UPDATE</code>, <code>DELETE</code>, <code>ALTER</code>, and <code>INDEX</code>.
 
** The database user must have the <code>CREATE</code> and <code>DROP</code> privileges during installation, conversion and some package installs.
 
** The database user must have the <code>CREATE</code> and <code>DROP</code> privileges during installation, conversion and some package installs.
* About 20 MB of storage space on the web server will be required.
 
 
  
 
==Server Recommendations==
 
==Server Recommendations==
 
''These are not required, but may be beneficial to your SMF install and enable you to use more functions.''
 
''These are not required, but may be beneficial to your SMF install and enable you to use more functions.''
  
* '''Windows, Linux or another Unix based operating system.'''
+
* '''GNU Aspell 0.50 or higher''' (with appropriate dictionaries) for spell checking functionality.
* '''GNU Aspell 0.50 or higher (with appropriate dictionaries) for spell checking functionality.'''
+
* '''Apache 2.0.x or above''' with '''AcceptPathInfo''' set to On for queryless URL support.
* '''Apache 2.0.x or above with AcceptPathInfo set to On for queryless URL support.'''
 
  
* '''PHP 5.2.0 or higher, with the following set in your php.ini file:'''
+
* PHP with the following set in your '''''php.ini''''' file:
** max_input_time set to a value of at least 30.
+
** <code>max_input_time</code> set to a value of at least 30.
** post_max_size and upload_max_filesize set to the size of the largest attachments you wish to be able to upload.
+
** <code>post_max_size</code> and <code>upload_max_filesize</code> set to the size of the largest attachments you wish to be able to upload.
** memory_limit set to at least 8M.
+
** <code>memory_limit</code> set to at least 32M.
** max_execution_time set to at least 15.
+
** <code>max_execution_time</code> set to at least 15.
** register_globals set to Off.
+
** <code>register_globals</code> set to Off.
** session.use_trans_sid set to Off
+
** <code>session.use_trans_sid</code> set to Off.
 
** safe mode disabled, or PHP suExec enabled.
 
** safe mode disabled, or PHP suExec enabled.
 
+
** [http://www.php.net/manual/en/book.bc.php BCMath] library enabled for using the [[Registration#Settings|OpenID]] registration method.
===Database Support===
+
** <code>mod_security</code> disabled (please see [[Mod security - Having problems with mod security|Mod security]] for more information).
* MySQL 5.0 or higher if you using MySQL.
 
* PostgreSQL 8.3.3 or higher if using PostgreSQL.
 
* SQLite 3.6.1 or higher if using SQLite.
 
  
 
* '''GD Graphics Library 2.0 or higher.'''
 
* '''GD Graphics Library 2.0 or higher.'''
  
 +
==Basic Client Requirements==
  
==Basic Client Requirements'==
+
* Microsoft Internet Explorer 6.0 or higher (7.0 or higher recommended).
 
 
* Microsoft Internet Explorer 5.0 or higher (7.0 or higher recommended).
 
 
* Opera 7.0 or higher (9.5 or higher recommended).
 
* Opera 7.0 or higher (9.5 or higher recommended).
 
* Netscape 6.0 or higher.
 
* Netscape 6.0 or higher.
Line 55: Line 52:
 
* Konqueror or Galeon.
 
* Konqueror or Galeon.
 
* Apple Safari 1.0 or higher (3.0 or higher recommended).
 
* Apple Safari 1.0 or higher (3.0 or higher recommended).
* Mozilla Firefox 0.8 or higher (2.0 or higher recommended).
+
* Mozilla Firefox 3.0 or higher (3.5 or higher recommended).
 
 
===Browser Settings Requirements:===
 
 
 
* Javascript and cookies should be enabled for full functionality.
 
 
 
'''Browsers that are not recommended or are unsupported:'''
 
* Mac IE 5.1.7 or higher.
 
* Opera 6.0.
 
* Microsoft Internet Explorer 4.0.
 
* Netscape Navigator 4.0 (unsupported).
 
* Microsoft Internet Explorer 3.0 (unsupported).
 
  
 
{{Installing SMF}}
 
{{Installing SMF}}

Latest revision as of 12:29, 27 June 2018

In order to run an SMF forum, the server must meet the following requirements, and will run best on servers that also meet the recommendations below. This software has been tested and verified to work with the clients listed below, which are all internet browsers.

Basic Server Requirements

The following are required on any server intending to run SMF 2.0.

  • A webserver with approximately 20MB of available disk space. Much more is recommended so that other content can be uploaded over time.
  • A webserver that supports PHP, such as Apache or Internet Information Server (IIS).
  • PHP 4.1.0 or higher
    • Versions of SMF below 2.0.7 will not work on PHP 5.5. If you use PHP 5.5 it is necessary to use SMF 2.0.7 or greater.
    • Versions of SMF from 2.0.14 onwards require a version of PHP between 5.4 and 7.1. If you use PHP 5.3 or lower, it is necessary to use SMF 2.0.13 or lower. PHP 7.2 is not supported by SMF at this time.
  • The following must be changed in the php.ini file:
    • The engine directive must be set to On.
    • The magic_quotes_sybase directive must be set to Off.
    • The session.save_path directive must be set to a valid directory or empty.
    • The file_uploads directive must be set to On.
    • The upload_tmp_dir directive must be set to a valid directory or empty.
  • One of the following databases must be installed:
    • MySQL 4.0.18 or higher (at least 4.1.0 would be better) and PHP MySQL client API 4.0.18 or higher.
    • PostgreSQL 8.0 or higher (standard_conforming_strings must be set to off, starting from PostgreSQL 9.1 default is on)
    • SQLite SQLite 2.x (SMF is not compatible with SQLite 3.x)
  • The following are requirements for the database:
    • For a clean SMF installation, at least 2 MB of storage space in the database. Please note that this is only enough for the installation.
    • The database user must have at least the following privileges: SELECT, INSERT, UPDATE, DELETE, ALTER, and INDEX.
    • The database user must have the CREATE and DROP privileges during installation, conversion and some package installs.

Server Recommendations

These are not required, but may be beneficial to your SMF install and enable you to use more functions.

  • GNU Aspell 0.50 or higher (with appropriate dictionaries) for spell checking functionality.
  • Apache 2.0.x or above with AcceptPathInfo set to On for queryless URL support.
  • PHP with the following set in your php.ini file:
    • max_input_time set to a value of at least 30.
    • post_max_size and upload_max_filesize set to the size of the largest attachments you wish to be able to upload.
    • memory_limit set to at least 32M.
    • max_execution_time set to at least 15.
    • register_globals set to Off.
    • session.use_trans_sid set to Off.
    • safe mode disabled, or PHP suExec enabled.
    • BCMath library enabled for using the OpenID registration method.
    • mod_security disabled (please see Mod security for more information).
  • GD Graphics Library 2.0 or higher.

Basic Client Requirements

  • Microsoft Internet Explorer 6.0 or higher (7.0 or higher recommended).
  • Opera 7.0 or higher (9.5 or higher recommended).
  • Netscape 6.0 or higher.
  • Mozilla Suite 1.0.2 or higher.
  • Konqueror or Galeon.
  • Apple Safari 1.0 or higher (3.0 or higher recommended).
  • Mozilla Firefox 3.0 or higher (3.5 or higher recommended).