Template:Which version number/doc

From Online Manual

< Template:Which version number
Revision as of 11:33, 20 January 2014 by Illori (talk | contribs)
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

This template will allow updating of the versions numbers currently supported Example:

{{Which version number|currentstable}}

The above would out put the current stable version that is stored in the variable currentstable in the template

  • currentstable The current stable version of the SMF software -- the first listed on the downloads page
  • currentseries The series to which the current stable version belongs (1.1.13 is in the series 1.1)
  • deprecatedseries The currently deprecated series; the series which is no longer current. With the release of 1.1, the 1.0 series became deprecated. Still supported. No new features to be added. Important bugfixes possible.
  • obsoleteseries Any previous series which is no longer supported, and for which no new bugfixes are to be released
  • currentstabledocs most completely documented version of smf on the wiki
  • depreciatedseriesdocs the last completely documented version of smf on the wiki
  • upcomingstabledocs the next coming version that is not totally complete on the wiki