SMF2.0:Requirements and recommendations

From Online Manual

Revision as of 21:43, 3 November 2010 by Trekkie101 (talk | contribs)
Jump to: navigation, search

To run an SMF forum the server it resides on, as well as the browsers used by its users, will need to meet some specified requirements. Additionally, there are some recommended requirements that may give advanced capabilities to users.

Basic Server Requirements

The following are required on any server intending to run SMF 2.0.

  • PHP 4.1.0 or higher
  • The following must be changed in the php.ini file.
    • The engine directive must be set to On.
    • The magic_quotes_sybase directive must be set to Off.
    • The session.save_path directive must be set to a valid directory or empty.
    • The file_uploads directive must be set to On.
    • The upload_tmp_dir directive must be set to a valid directory or empty.
  • One of the following databases must be installed.
  • The following are required of the database.
    • There must be at least 2 MB of storage space in the database, although more is highly recommended.
    • The database user must have at least the following privileges: SELECT, INSERT, UPDATE, DELETE, ALTER, and INDEX.
    • The database user must have the CREATE and DROP privileges during installation, conversion and some package installs.
  • About 20 MB of storage space on the web server will be required.



Server Recommendations---- These are not required, but may be beneficial to your SMF install and enable you to use more functions.

  • Windows, Linux or another Unix based operating system.
  • GNU Aspell 0.50 or higher (with appropriate dictionaries) for spell checking functionality.
  • Apache 2.0.x or above with AcceptPathInfo set to On for queryless URL support.
  • PHP 5.2.0 or higher, with the following set in your php.ini file:
    • max_input_time set to a value of at least 30.
    • post_max_size and upload_max_filesize set to the size of the largest attachments you wish to be able to upload.
    • memory_limit set to at least 8M.
    • max_execution_time set to at least 15.
    • register_globals set to Off.
    • session.use_trans_sid set to Off
    • safe mode disabled, or PHP suExec enabled.
  • Database Support
    • MySQL 5.0 or higher if you using MySQL.
    • PostgreSQL 8.3.3 or higher if using PostgreSQL.
    • SQLite 3.6.1 or higher if using SQLite.
  • GD Graphics Library 2.0 or higher.


Basic Client Requirements

  • Microsoft Internet Explorer 5.0 or higher (7.0 or higher recommended).
  • Opera 7.0 or higher (9.5 or higher recommended).
  • Netscape 6.0 or higher.
  • Mozilla Suite 1.0.2 or higher.
  • Konqueror or Galeon.
  • Apple Safari 1.0 or higher (3.0 or higher recommended).
  • Mozilla Firefox 0.8 or higher (2.0 or higher recommended).

Browser Settings Requirements:

  • Javascript and cookies should be enabled for full functionality.

Browsers that are not recommended or are unsupported:

  • Mac IE 5.1.7 or higher.
  • Opera 6.0.
  • Microsoft Internet Explorer 4.0.
  • Netscape Navigator 4.0 (unsupported).
  • Microsoft Internet Explorer 3.0 (unsupported).